I can do everything EXCEPT view\/control.

Post Reply
Guest

I can do everything EXCEPT view\/control.

Post by Guest » Mon Aug 29, 2011 2:43 pm

So here's the deal.  My company bought a 2010 Mac Mini Server with Snow Leopard at my request.  It hosts VMs which employees use for lab purposes; nothing heavy.  I installed it in our server room and it was working fine.

 

At first I had a Dell laptop and tried to set up VNC access; it would not connect.  I brought my personal 2011 MacBook Pro in to work and connected it, still couldn't connect using VNC.  Using Remote Desktop, I was able to add the computer and set my Pro as the administrator.  I could see it fine, but could not connect.  But I noticed that if it asked me for username and password, I could get it to work.  If it just asked for a password, I could never connect.  No matter what password I entered it would not function.  "Authentication failed".

 

Rebooted the server, all of a sudden I could connect...for a while.  After a while though, I would connect and be unable to do anything.  I can see the menu change as I click between windows and the desktop so I know I'm connected.  But none of the buttons or anything respond.  I close the console window, and then attempt to reconnect, and get "Authentication failed".

 

So...fast forward.  Company buys me a MacBook Pro at my request.  I load up Apple Remote Desktop and set the work Pro as administrator for the Mac Mini Server, and redeploy the package.  Can't connect.  So I physically move the Mac Mini Server out to my desk and connect it to my secondary network drop; Apple Remote Desktop connects perfectly every time.  We put it back in the server room and change the switch port so that while in the server room it's connected to the same port that it would be if it were at my desk.  Connects fine...but then again, eventually it just drops and I get Authentication failed.

 

Now here's the thing:

  • I can ping it.  Which means it's not a connectivity issue.
  • I can see it says "Online" in ARD, which means Apple Remote Desktop is functional on both the client and the server.
  • I can issue commands to it.  I can tell it to launch an app, restart, etc. which means ARD is functioning and authentication is actually successful.

 

Now, based on what I know of computers, it almost seems like the VNC sessions are getting "locked" somehow.  As if it can't create a new session because there's already one there.  Problem is I don't know if that's what is happening, or why, or what to do about it.  I need to be able to view/control this server readily, which is part of why I bought Apple Remote Desktop in the first place.  I don't have this issue on any of my home machines, which seems to tell me that the server OS might be the cause.

 

Long winded, yes.  But does anyone have any suggestions?


Guest

Re:I can do everything EXCEPT view\/control.

Post by Guest » Mon Aug 29, 2011 3:25 pm

I have the same problem. All of my settings on my computers(home network) are the same including the firewalls.One computer running Lion will not show up as screen sharing in the finder and the contol and observe functions will not connect but the other functions of ARD seem to work OK.

Guest

Re:I can do everything EXCEPT view\/control.

Post by Guest » Mon Aug 29, 2011 3:35 pm

My issue turned out possibly being a larger problem. 

 

All of a sudden the server is in a bad, bad way.  30 minutes to get booted to the login screen.  If I try to login I get beachballs for half a second at a time.  I type login/password, the screen refreshes and I'm back to the login screen.  I can't connect a keyboard/mouse directly to it, because it wants to do the keyboard recognition (I'm not using an Apple keyboard because they're all Bluetooth and I can't get in to do the Bluetooth sync).  I can't do Disk Utility, because I can't connect a keyboard to do the key shortcut.  I can't do Hardware Test, because I can't connect a keyboard to do the key shortcut.  Can't reinstall Snow Leopard Server, because in their infinite wisdom Apple has removed the optical drive, and even if I had the optical, it wouldn't do any good because I can't connect a keyboard to do the key shortcut that would allow me to boot from the DVD.

 

I tried to do target disk override from Remote Desktop but it won't let me choose my other Mac's Remote Disc as a boot option.  It also continues to show the Server as "Offline" even though power is on and it's on the network.

 

I would do my 2010 Air's USB drive - just to do a Disk Utility and see if it's a drive problem - but I can't tell the Server to boot from the USB stick.

 

Tried using my iMac as a monitor, that worked for a while, now it just flashes and then goes back to the iMac.

 

I'm thinking the logic board on this thing is about to die.  Which is unfortunate, since my company opted out of AppleCare for this piece of equipment, and the 1 year expired last month.  So...if the repair is going to end up being $800, they're going to have to pony up for a new server.


Guest

Re:I can do everything EXCEPT view\/control.

Post by Guest » Mon Aug 29, 2011 3:52 pm

I had the same problem with some university computers I was using. Try turning ARD client on and off on the Mini.

 

You need to use these commands from the client or SSH into it because it will turn off your ability to control from the Admin machine until you run the second one.

 

sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/k ickstart -deactivate -configure -access -off

 

sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/k ickstart -activate -configure -access -on -restart -agent -privs -all

 

Hope that helps. It solved my problems.


Guest

Re:I can do everything EXCEPT view\/control.

Post by Guest » Mon Aug 29, 2011 4:10 pm

Already tried kickstarting, no go.  The only way it comes back up is by rebooting the server completely.  Which of course is not a practical option.

 

We got the server fixed, it was a bad hard drive, apparently even from the very beginning.  I noticed it was slow but assumed it was the Server OS that was slower than the client.  After swap it's back to good performance. 


I have identified a pattern.  So my MacBook Pro connects normally via Ethernet but we also have an internal wireless that is attached to the same network.  Our computers are configured for both the Ethernet and wireless connections, that way we can always connect to the network even if moving throughout the buildings. 

 

If I am attached Ethernet and I communicate with ARD, and it works, it will continue working until I disconnect and go wireless, even if I then later re-connect Ethernet.  Thinking there might be an IP issue, I disabled the Airport completely and just did Ethernet, but it won't pick back up until/unless I reboot the server.  Then it works fine until the next time I disconnect.  The problem is that it's a laptop - it's going to be disconnected frequently, and I need ARD to just work regardless.

 

I opened up the firewall log and didn't even see the activity of it connecting to the server - none.  But again, I can send commands to it, I can file share to and from it, everything except control.  So it seems there might be some problem with the VNC connection that's being used.

 

I wish there were an application similar to vSphere for the Mac, then I would just use the server as a host while I configure and administer them from afar.


Guest

Re:I can do everything EXCEPT view\/control.

Post by Guest » Mon Aug 29, 2011 4:40 pm

Ok, I think I figured out the problem, though I don't understand the "why" of it.

 

So when I deployed the first package my MacBook Pro was configured on both Ethernet and wireless.  It seems the package may bind to a single IP, likely for security reasons, because when I disable wireless, that's when it doesn't work.  If wireless is on, it works, regardless of Ethernet connection state, even though the Mini is only connected via Ethernet and its wireless is disabled. 

 

Previously I left wireless on so I could manage my internet connection no matter where I was, but if I can't have Remote Desktop work regardless of which adapter is active, that's unfortunate.  I was hoping it would just give a computer name rather than focus on IP, since the computer name is fixed.

 

What I did is:

  1. Disable wireless completely, so my machine only has one active adapter
  2. Create a new installer package
  3. Run the installer package from within Remote Desktop to the server

 

Now, whether wireless is on or not, it seems to work fine.  I'm going to do more testing, then I'll update.


Post Reply