I've uploaded my iWeb 08 site to Linux...

Post Reply
Guest

I've uploaded my iWeb 08 site to Linux...

Post by Guest » Thu Jan 12, 2012 2:03 pm

My website looks great in iWeb, but I cannot get it to become visible online, even thought the FTP File Manager shows it as published.  I have moved all the files for it to the FTP site. This is my first experience with publishing a website, and w/using iWeb and FTP sites.  The instructions were very simple to publish form iWeb to a folder, I followed them to the letter, with godaddy tech support, that was effortless.  I have just published a godaddy shopping cart, also effortlessly.  I just can't see the site .... please help!! 

Guest

Re:I've uploaded my iWeb 08 site to Linux...

Post by Guest » Thu Jan 12, 2012 3:22 pm

Once published to a folder, iWeb job is done. Now it is your responsibilty to put the files where they belong. Check that you published to the correct folder.  And here is how you :Set up Godaddy domain and use Cyberduck<

Guest

Re:I've uploaded my iWeb 08 site to Linux...

Post by Guest » Thu Jan 12, 2012 3:26 pm

Hello, Wyodor! Thank you for taking time to reply .... I just want to make sure I understand all this ... please bear with me, I'm trying to learn .... I'm not sure why I would need Cyberduck?  I know nothing about Cyberduck, although I have heard of it.  Does the Linux hosting I have not do the same thing? I have my godaddy account all set up,  My domain is through them, I have their Linux hosting account, the FTP account that goes with it, and I can see the same list of files in the FTP File Manager that I see listed in the iWeb folder which I published to. Yesterday, the website was up, but the welcome page was missing the nav bar, and it was showing black text on the black background(unless I highlighted it, like selecting text), so they had me re-do the Welcome page (which was missing the nav bar), re-upload all the files again, and that's when I started getting the 404 message, and can no longer even see the black page.   If the files are not in the correct place, how do I know?  I uploaded them directly via the FTP File Manager upload window from the folder holding the iWeb site, and I only have the one domain.  How can I check whether the files are in the right place?  There is a root directory titled html and a subdirectory titled Site, which contains all the iWeb files, and I have options to check and move files around. Thank you for helping!

Guest

Re:I've uploaded my iWeb 08 site to Linux...

Post by Guest » Thu Jan 12, 2012 4:38 pm

Short answer. Check that you uploaded the files to the right location. According to every FAQ/Help/Support article it's the public_html folder. And since you published to a folder and do the uploading yourself, it's not an iWeb issue anymore. Sounds awful.If the files are not in the correct place, how do I know?They don't show in the browser. That's the reason of your being here. Check the location. And check it again. And perhaps using Cyberduck gives you a different view of the directory.

Post Reply